Zend_Loader のエラー???

先ほど、Zend Frameworkを1.8にバージョンアップしたところ以下のメッセージが出るようになってしまった。。。

Notice: Zend_Loader::Zend_Loader::registerAutoload is deprecated as of 1.8.0 and will be removed with 2.0.0; use Zend_Loader_Autoloader instead in /var/www/*****/library/Zend/Loader.php on line 207

非常にあせったが、検索してみると同じ症状で対処方を載せてくれている方いたのでそれを参考にしてみた

今まで、

require_once ‘Zend/Loader.php’;
Zend_Loader::registerAutoload();

としていたところを

require_once ‘Zend/Loader/Autoloader.php’;
$autoloader = Zend_Loader_Autoloader::getInstance();
$autoloader->setFallbackAutoloader(true);

にすれば良いらしい

あんまり意味は分かってないけど、直ってよかった

タイトルとURLをコピーしました